EC25A on Linux 5.x

I am trying to use quectel-CM with an EC25A over USB on Linux 5.4.50 (distro is archlinuxarm) on Raspberry Pi.

The interface wwan0 is created and quectel-CM seems to connect successfully, but my dhcp client never gets an IP, and I never see any incoming packets on the interface with tcpdump.

I see that there are some patches floating around for the 4.19 kernel, but a quick look at the 5.x source code seems to show that most of these changes have maybe already been upstreamed…

Anyhow, I’m wondering whether I should expect a 5.x kernel to work unpatched, or if perhaps there are some updated patches out by now?

@bmork git blame shows you maybe authored some of these patches? Any thoughts?

I beieve the EC25A should work on any unpatched and maintained kernel after v4.5. We continously add the device IDs we get to know about, and these patches are backported to all the stable/longterm kernels.

I don’t know much about quectel-CM, but the symptoms you describe sounds like what would happen if the wwan0 interface isn’t put into ‘raw-ip’ mode. Let’s check that first. The ‘raw_ip’ sysfs attribute should say ‘Y’, and the interface look a bit weird with HWaddr being a long string of zeroes, similar to this

root@wrt1900ac-1:~# grep . /sys/class/net/wwan0/qmi/raw_ip 
root@wrt1900ac-1:~# ifconfig wwan0
wwan0     Link encap:UNSPEC  HWaddr 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00  
          inet addr:  P-t-P:  Mask:
          inet6 addr: fe80::a3de:33a7:baf:83d8/64 Scope:Link
          RX packets:27205 errors:0 dropped:0 overruns:0 frame:0
          TX packets:23574 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:1333613 (1.2 MiB)  TX bytes:1109132 (1.0 MiB)

Pardon the long delay - I finally got another chance to test on a newer kernel (5.4.61) and can confirm that the interface is not in raw mode just as you suspected. I ran:

echo Y > /sys/class/net/wwan0/qmi/raw_ip

and the packets started coming through. Thanks for the help!

Glad to hear that the issue have solved. Thanks for your sharing.@bmork