BG96 MQTT ThreadX Demo Application connection issues

Hello @Stephen.Li-Q

I have tried to connect to Azure IoT Hub with and without a CA root certificate. Both attempts have failed. I have debugged this for over a month and I am not sure where the issue lies. Is it possible to provide an example of how one would connect to Azure IoT Hub via ThreadX MQTT demo application? The MQTT demo itself does not seem to work out of the box.

for Azure you need Microsoft accaunt to Asure, activated device, and private key for SAS pasword calculation ( test with DeviceExplorer, there get your SAS password )

if other platform as PC, ESP32 etc connect to Asure and if BG96 connect to mosquito/eclipse with secured mqtt server then your BG96 project will work with Azure
first test without CA next with CA and if have problems connect with Quectel and explain issue

for MQTT & Asure you need secured mqtt client, ClientID, UserName and Password(SAS) and/or CA
read Microsoft documentation

My tests ( before one year, I lost the project/example ) is OK
for now my free Azure account expire and in my HomeOffice (K-19) I not have BG96 module for test and provide example

@ Lawrence.Wan
send me your source code to see… my email - get from my GitHub

Hello @WizIO

I have a Microsoft Azure account setup and it is currently working fine as I can connect to my Azure IoT Hub server through BG96 via AT commands and SAS token.

With threadx I was able to connect to test mosquitto only through an unsecured port(1883).
I have looked at the Azure documentation for the required fields(username, password, client id, etc…) and have tried with SAS token(with or without a CA certificate which is even registered on my IoT Hub). I am currently still trying to connect with Quectel support about this but response is not frequent.

I will send the source code that I am using via email.

Hi lawrence

if this issue disturb you still ,pls send email to us