BG96 connect to leshan server fail by LwM2M

Use “AT+QLWM2M?” command and configure file(bootstrap.ini, carrier_apn_cfg, lwm2m_cfg and qcli_config)
to connect to leshan Lwm2m server(coap://leshan.eclipseprojects.io:5683) using a non secure connection
but can not register…
The log as below:

Net: Net Registered
dss_netapp: DSS_NetApp Registered
atfwd_cli_app: Atfwd_Cli_App Registered
LWM2M_EXT: LWM2M_EXT Registered

Command List:
Commands:
1. Help
2. Exit

Subgroups:
3. Net
4. dss_netapp
5. atfwd_cli_app
6. LWM2M_EXT

LWM2M: CLI registered
LWM2M: LWM2M_LOG:Carrier type = 0
LWM2M:
LWM2M: REG EP NAME = 4
LWM2M:
LWM2M: BOOTSTRAP EP NAME = 4
LWM2M:
LWM2M: LWM2M_LOG: bootstrap_name --> urn:imei:866425030064275
LWM2M:
LWM2M: State: STATE_REGISTER_REQUIRED
LWM2M: State: STATE_REGISTERING

Which configure parameter error cause registering fail?
Here’s my config file https://drive.google.com/file/d/1axldayXSLdDIFRcl91xa7Nc7i0S_zENt/view

Thanks.

Hi tim_lai

Pls use the config file in the below link :
https://cnquectel-my.sharepoint.com/:f:/g/personal/america-fae_quectel_com/ElSmaAsY9rFDn3Y3mgoYOTQBm7fiCML6HUIqphYCuUzH8Q?e=yM8dcK

Hello Stephen,

I have the same issue as tim stated above.
I used your config file and didn’t work.
Since “coap://leshan.eclipse.org:5683” is not working, I’ve used “coap://leshan.eclipseprojects.io:5683”.
However, the result was same.

I’ve tried several methods…
Method 1:
AT+QLWM2M=“select”,0
AT+QLWM2M=“enable”,1
AT+QLWM2M=“qcli_en”,1
AT+QLWM2M=“register”
And restart

Method 2:
AT+QLWM2M=“select”,0
AT+QLWM2M=“enable”,1
AT+QLWM2M=“cdp”,“coap://leshan.eclipseprojects.io”,5683 or (“coaps://leshan.eclipseprojects.io”,5684)
AT+QLWM2M=“psk”,0
AT+QLWM2M=“psk”,1
AT+QLWM2M=“qcli_en”,1
AT+QLWM2M=“register”
And restart

What exact steps do I need to do from BG96?
I would like to know the steps for “with PSK” and “without PSK.”

Thanks

when you use config file , Pls keep at cmd setting as default , just use config file and reboot, and then waiting debug port output .

These two are parallel

Stephen,

I’ve used default settings and didn’t work.
I’ve changed config file and didn’t work.
I tried so many different ways(combine default settings and config) and all failed.

Just let you know that I used those two methods to set default values and didn’t include config file.
Later on, I implemented config file because it didn’t register.

Hi da_Y

Pls send email to : support@quectel.com

we will send to you modem log tools , pls collect log ,we will do more analysis based on your log ,

thanks